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1 Apresa Client 

1.1 Apresa Client Introduction 
 

This is the manual of the Apresa Client, a client for Vidicode Call 

Recorder Apresa. Apresa Client is PC software that can be used to do 

screen recording, start and stop recordings, make notes, and perform 

other actions on active calls. The Apresa Client communicates with the 

Apresa server machine. It is intended to be used by users or agents that 

have a telephone that is recorded by the Apresa server. You can use 

Apresa Client for Free Seating. 

 

 
 

 

1.1.1 Configuration in the Apresa web interface 

 

Options → Users 

 

For users to use Apresa Client, they must have an enabled Apresa 

account. To create a user account, open the Apresa web interface and 

log in as administrator, and go to the users screen. When creating the 

new account, also specify the telephone (or telephones) belonging to 

the user. Calls that involve these telephones are reported to the Apresa 

Client, to trigger, for example, screen recording. 
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1.1.2 Screen recording 

 

Apresa Client for Windows → File → Options → Screen 

 

To enable screen recording, the "Screen recording" option must be 
enabled in the Options of the Apresa Client. Screen recording starts 

when a call is initiated or received, and stops when the call stops. The 

screen recording is then uploaded to the Apresa server. You can 

download the screen recording of a call in the Home tab of the Apresa 

web interface. Select a call and click on the ‘Download screen recording’ 

 button. 

 

Options → Recording settings 

 

Note: In the call listing of the Apresa web interface, you will easily see 
which recordings have screen recordings attached to them, if you enable 
the Visible Column “Special properties of the recording” in the 
Recording Settings. 
 

Differences between video file formats 

Apresa Client creates screen recordings in wmv format. Apresa Client 

Professional is able to create screen recordings in mp4 format. You can 

download wmv and mp4 files and watch them on you PC. 

Note that wmv files are playable in Internet Explorer, while mp4 files are 

playable in modern browsers like Chrome, Firefox and Edge. 

 

1.1.3 Blank a Part of a Screen Recording 

 

Options → Recording settings 

 

In the Recording settings of the Option menu, turn on Silence on 

Demand. 

 

Apresa Client for Windows → File → Options → Hotkey 

 

● Click on the Start Silence edit box and press a key, for example, F6. 

● Click on the Stop Silence edit box and press a key, for example, F7. 

● Start the call 

● Before you are about to view privacy sensitive information, e.g. 

somebody’s home address, press the “Start Silence” key you have 

chosen. 

● Press the “Stop Silence” key you have chosen to continue the screen 

recording. 
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● End the conversation 

 

Result: there will be a screen recording, with a blank part in it. 

 

1.1.4 Adding notes during a call 
 

 
Edit the notes field to add a note to the call. 

 

1.1.5 Closing the Apresa Client 
 

Go to the Apresa Client (in Windows). When you click on the close 

button  of the main screen, the main screen will close, but the 

application will be remain active in the background. To close the 

application completely, right-click on the Apresa Client icon in the 

system tray, and choose Exit. 

 

1.2 Apresa Client Menu 
 
File  

● Account: Set the username and password for logon to Apresa. This 

screen can be reached also when the options screen is locked with a 

password.  

● Options: Change the configuration.  

● Licensing: Only available in the Professional version for managing 

the license  

● Log Files: Opens in explorer the directory that contains the log files  

● Exit: Closes the application  

 

Help  



Call Recorder Apresa Client Manual © 2022 Vidicode ® 

 

6 

● Contents: Opens the inline manual.  

● Check for update: Checks for updates online. Updates can be 

installed here too.  

● About: Show version information.  

  

1.3 Apresa Client Options 
 

Apresa Client for Windows → File → Options 

 

To open the options screen of the Apresa Client, choose Options from 

the File menu or click on the  button. 

 

1.3.1 Apresa Client: account settings 

 
Apresa Client for Windows → File → Options → Account 

 

 
 

On the account tab, input your Apresa username and password. 
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1.3.2 Apresa Client: server connection with Apresa 

 

Apresa Client for Windows → File → Options → Server Connection 

 

 
 

 
 

Apresa Server IP address: The IP address or IP name of the Apresa server. 

If a non-default port is used, add a colon and the port number, for 
example: 1.2.3.4:9000 

Secured HTTPS connection: When this option is enabled, Apresa Client 

will communicate with Apresa using the HTTPS protocol. For this to 

work, it is needed that HTTPS is also enabled and configured on the 

Apresa server. 

 

1.3.3 Apresa Client: Screen 

 

Apresa Client for Windows → File → Options → Screen 
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Screen recording: If this option is enabled, a recording of what is visible 

on the screen will be made during a call, and uploaded to the Apresa 

server afterwards. 

Standard: The standard screen recording method is available by default. 

Recordings are in WMV format. 
Advanced: The advanced screen recording method is available only in 

the Professional version. Recordings are made in MP4 format. A higher 

capture framerate might be possible. 

FPS: The number of frames per second of the screen recording. A higher 

value gives a better quality video, but requires more CPU power and disk 

space. 

Continue recording after end of call: The screen recording will continue 

until the specified number of seconds have elapsed, or until a new call 

starts. 

Merge audio and screen recording: Merge the audio recording, as 

provided by the Apresa server, with the screen recording. This option is 

enabled by default. The merging process takes place after completion of 

the call, and uses much CPU power. 

Record multiple monitors in one row: If multiple monitors are recorded, 

record all the monitors simultaneously in one (wide) row, in one file. For 

the advanced screen recording method, this is always done. Otherwise, 

monitors are recorded separately and stored in separate files, and 

combined together in a compressed zip file. 

Screens to record: If the PC has more than one monitor, choose here 

which monitors should be recorded. The monitors are recorded 

separately, and the separate screen recordings are uploaded to the 

server in a combined .zip file. Known problem: The mouse cursor is not 

captured correctly in a multi-monitor setup. 
 

Extra settings for the Advanced screen recording method: 
 

Show mouse clicks: Mouse clicks are visually shown in the screen 

recording using a colored circle. 

GPU acceleration: This can improve the fluency and speed of the capture 
and lower main CPU usage (enabled by default). Disable in case of 

incompatibility. 
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1.3.4 Apresa Client: Actions 

 

Apresa Client for Windows → File → Options → Actions 

 

 
 

Recording on demand: Shows a button "Start recording" to start 

recording of a call "on demand" at the click of the button. For this to 

work, "Recording on demand" must be enabled for the local telephone 

number or channel. 
Store on demand: If this option is enabled, a button "Store this call" is 

displayed in the main screen. When this button is pressed, the current 

call will be stored. This option is only relevant when the option "Store 

on demand" is enabled in the Recording options on the Apresa Server. 

Silence on demand: If this option is enabled, a part of the recording of a 

call can be silenced by pressing the "Start silence" button during the call. 

To start recording audio again, press the "Stop silence" button. When 

portion of a call is silenced, the screen recording will be blanked out as 

well. This option only works if "Silence on demand" is enabled in the 

Recording options on the Apresa Server. 

Silence during this window title: Click the [...] button to define the 

window titles to scan for. If an application window is found that 

contains the specified text in its title, silencing will be activated 

automatically. Screen recording is also blacked-out when silencing. 

The window title of browsers usually contain the title of the web page 

that is visited. 

It is possible to let it scan for multiple window titles. If one of them is 

present, silencing is activated. When none are present anymore, 

silencing will again be deactivated automatically. 
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Manually enter the window title in the text box, or choose from one of 

the currently detected window titles (click the small drop-down arrow 

button). Then press Add to add the window title to the list of items to 
scan for. 

To edit an existing item, select it, edit it using the text box, then press 

the Edit button. 

To delete an item, select it, then press Delete. 

When the configuration is correct, press OK. 

 

Set category: If this option is enabled, a call can be assigned to a 

category. Categories are defined on the Apresa server (Options, System 

settings, Category tab). 

Edit notes: If this option is enabled, notes can entered during a call and 

saved. The user must have the permission to edit the Notes field. 

Edit notes (2): The same for the secondary notes field. 
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1.3.5 Hotkey 

 

 
 
 

Hotkeys are keyboard shortcut combinations to do an action (such as 

starting the recording), even when the program is in the system tray, 

and you are working in another application. The shortcuts can use Ctrl, 

Alt, and Shift, and a combination of those, plus another key on the 

keyboard, for example: Ctrl + Shift + X. Single keys are not accepted as 

hotkey. When using only the Shift key, only the function keys (F..) are 

accepted. When a hotkey is defined, the key combination might have no 

longer any effect in other applications, so choose carefully to avoid 

conflicts (for example, don't define Ctrl + S as hotkey). To define a 

hotkey, place the cursor in the edit box, and then press the key 

combination. To remove a hotkey, press Backspace. It is allowed to reuse 
a key combination for multiple purposes, for example, it is allowed to 

have one key combination for both starting and stopping the recording. 
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1.3.6 Display 

 

 
 

Information: 
● Identifier: Displays a unique identifier (ID) of the call, that can be 

used later to lookup the call in the web interface.  

● Notify about new calls in system tray: If the program is active in the 

system tray (main window closed), and a new call is detected, this is 

shown in a notification message. Clicking the message opens the 

main window.  

 

Language: 

● The interface language can be chosen here: Danish, German, English, 

Spanish, French, Greek, Italian, Dutch or Polish. 

 

 

1.3.7 Start / Exit 

 

 
 

Start-up with Windows: Start the program at logon in Windows. 
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Start-up in System Tray: Start the application in the system tray (the 

lower right area in Windows). 

Stay active in system tray, when main window is closed: When this 

option is on, the software will move to the system tray and continue to 

record calls, when the main window is closed. To completely close the 
software, right-click on the system tray icon, and select Exit, or choose 

File, Exit from the main menu. 

 

1.3.8 Security 

 

Password for options: The specified password must be entered before 

this settings screen is opened. 

 

1.4 Apresa Client PRO Licensing 
 

This applies only to Apresa Client PRO. 

 

Move a license to another PC 

On the old PC, start the software, choose Menu, Licensing. 

Then click the Deactivate button. 

The uninstall program will also attempt to deactivate. 

Then Activate the key on the new PC. 

 

Offline activation of a license 

Perform normal license activation. When the program detects it  

Cannot reach the server, it will display information for offline activation. 
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2 Free Seating and the Apresa Client 

 

When a company uses free-seating, employees don’t have a fixed seat. 

For example, a seat consists of a PC and a telephone. The other 

employees work during other shifts or they have chosen other seats to 
work from. 

2.1 When you don’t need the Seats Configuration 
 

The Apresa will try to detect the user from the protocol data, for 

example when a user has his own unique telephone number, or when 

the Apresa can detect the log in of the user. Fill in the unique telephone 

number in the Apresa web interface, in the settings page of the user. 
You’ll find the telephone number in the call listing of the Apresa, when 

this telephone made at least one call. 

 

2.2 Configuring the Seats Configuration 
 

See the Call Recorder Apresa manual for more information in this 
subject. 
 

If the Apresa can’t assign a call to a user in the ways described above, 

you might want to use the Seats Configuration. 

 

The Seats Configuration only works if you install the Apresa Client for 

Windows on the PC of a seat. First make sure the Apresa Client works 

without the Seats Configuration. Then continue. 

 

Find the exact name of the PC in the Windows Settings. 

 

 
 

Find the caller ID of the phone in the Home Screen of the Apresa. In this 

example the local ID is “117”, but in many cases it is a MAC address. 
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Go to Users of the Options menu and click on a user. Click the “Edit” 

button and click on the link to the Seats Configuration. Assign a 

telephone to a PC there. Fill in the exact name of the Windows PC (for 

example “WIN-V6V9D8S83PT”), and fill in a number that identifies the 

telephone. This can be: 

● a channel number (non-VoIP) 

● a caller ID (VoIP) 

 

In this example PC “WIN-V6V9D8S83PT” and telephone "117" make up a 

seat. Fill in all seats, on separate lines, that you want to make available. 

Please note the extra comma. 
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Turn on "User account for free-seating" for every user that will use free 

seating. 
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The configuration is completed. 

 

2.2.1 Summary of the Seats Configuration 

 

The user chooses a seat to work from. With Apresa Client, running on 

the PC of this seat, he logs on to the Apresa with his username and 

password. Apresa Client will send the name of the PC (e.g. “WIN-

V6V9D8S83PT”) and the user name (e.g. “Eric”) to Apresa. In the Seats 

Configuration “WIN-V6V9D8S83PT” and “117” make a seat. Therefore 

Apresa will assign calls made by telephone “117” to “Eric”. This way 

Apresa is able to assign telephone calls to a user. 


